Overview

    Preferences can be set on a per-user and studio-wide basis, and a set of studio-wide defaults can also be provided. They are found under File->Preferences (Windows/Linux) or qube->Preferences… (OS X).

    Which Setting Wins? (Preference Resolution)

    There are 4 levels of preferences, and each level overrides all levels above it. Preferences loading order (last one loaded wins)

    1. The Factory Defaults are built into the QubeWranglerView. 
    2. The Studio Defaults will be loaded first and will override the Factory Defaults. 
    3. The User Preferences are loaded next and will override the Studio Defaults and Factory Defaults.
    4. Finally, the Studio Preferences are loaded, and override the User Preferences, the Studio Defaults, and the Factory Defaults.


    More simply

    • Preferences override Defaults
    • Studio overrides User

    Studio-Wide Preferences

    An administrator can set up preferences and defaults to be used by the entire studio. This helps with support since everyone will be seeing the same interface. It can also be used to simplify the interface and/or hide potentially destructive tools from random users.

    If the user attempts to set a preference that has been set by the Studio Preferences, a warning message will be logged in the Log Pane and to the console, and the user preference will be ignored.

    Studio preferences require two steps: defining them, and then using them in the UI. Unfortunately, it is not currently possible to force users to use an external preferences file - they must reference it themselves (saying that, using the appropriate environment variables and a wrapper around the 'qube' command may be useful - see below). In a future version of Qube!, this will be changed so that the Admin can configure the UI globally without user help.

    Creating Studio Preferences

    First, configure the UI the way you would like it to be for the studio. Then save an external Preferences file, by selecting "File->Save External Preference File…". and save it some place that all users can reference it.

    These external preference files are Python dictionaries stored as plain text. They can be edited with a text editor, but Python syntax for a dictionary must be maintained, so be careful about accidentally deleting closing "}" characters, etc.

    Some of the UI layout preferences that are automatically saved in the user's preferences such as the WranglerView window size and the position of the various "sashes" that provide horizontal and vertical separation of the user interface are not saved to external preference files, but can be cut & pasted from a user's preference file into a saved external preference file should the administrator wish. The Factory Defaults already provide a set of values for these UI elements which should serve the first time the UI is started.

    Using Studio Preferences

    To reference an external preferences file as the Studio Preferences file, do one of the following:

    • In the Preferences Dialog, fill in the Studio Preferences field to point to that file.
    • From the command line, launch the QubeGUI (qube) with the command line option --studioprefs <fileForPreferences>
    • Set the environment variable QUBEGUI_STUDIOPREFS to point to that preferences file.

    Using Studio Defaults

    You can save an external preferences file that is used to define the studio's default UI settings as well. Simply save the current settings to a different named file. To reference a Studio Defaults file, do one of the following:

    • In the Preferences Dialog, fill in the Studio Defaults field to point to that file.
    • From the command line, launch the QubeGUI (qube) with the command line option --defaultprefs <fileForDefaults>
    • Set the environment variable QUBEGUI_DEFAULTPREFS to point to that preferences file.
    Icon

    Please note that the Studio-wide values are only loaded at startup. If you set either the "Studio Preferences" or "Studio Defaults" in your local prefs, you will need to restart WranglerView in order to have the studio-wide settings take effect.

    External Viewers vs Image Viewer

    You can define an Image Viewer which is used to display all image types - several common ones are provided using the Image Viewer Presets button.

    You can also define specific viewers (called External Viewers) for specific file formats. This allows you to use, for example, a particular viewer for exr files. The External Viewer will take precedence over the Image Viewer setting, so that the External Viewer will be used for file formats that are specifically called out, and the Image Viewer will be used for the rest.

    Preferences by Section

    The preferences dialog in the WranglerView is large, and is divided into sections. We'll treat each one in turn.

    Qube Config

    • Refresh Interval (min): By default, you must request an update on job status from the Supervisor. But you can configure this to happen automatically. Check the box, and set the delay in minutes between refreshes. This will refresh all jobs.
    • Refresh Select (sec): Check the box and set the interval, in seconds, between automatic refreshes of selected jobs only. Resist the temptation to overtax the Supervisor by asking for constant updates that you will probably not be using.
    • Supervisor Override: The UI connects to the first Supervisor that it finds, and in most cases that should be the only one. But if you have another supervisor, say on another subnet or in another domain, you can name it here and check the status of the jobs it is managing. Fill in either the fully qualified name (eg, mysupervisort2.studio.com) or the IP address.
    • Save/Restore Layout: If this is checked, WranglerView will save the current layout on exit, and restore it the next time you run it. If not checked, it will start up with the factory default layout.
    • Studio Preferences: The path to a previously saved preferences file that defines your settings. This will override your own preferences, and it will override the defaults. See above.
    • Studio Defaults: The path to a previously saved preferences file that defines your settings. This will override the Qube! factory defaults. See above.
    • Image Viewer Presets: Several pre-configured command strings to use some common external viewers.
    • Image Viewer: Optional third-party viewer. This will be run for all image types. To define viewers for specific formats, use the External Viewers option below.
    • Image Viewer Options: Options to send to the third-party viewer. The options field accepts a string that will substitute the following %(...)s fields – %(files)s, %(file)s, %(start)s, %(end)s, %(frames)s. If left blank, then %(files)s is assumed, that will send the full list of images.
    • External Viewers: Intended to allow different viewers for different file formats. For example, if you want to use a free viewer for jpeg files, so that you don't use up licenses of your not-free exr viewer application. File Pattern is a glob pattern, like *.jpeg
    • SimpleCmd Additional Paths: Additional directories that contain SimpleCmd submission UIs, typically custom to your facility.
    • Job Defaults Method:
    • Path Translation Map:
      At submit-time, paths can be automatically translated so they match what the render farm Workers expect. It is a simple string replace. Set the "From" field to the value to change, and the "To" field to the new value. It will perform the path translation based on the order of the listed map items. 

      Examples:

      • Converting OS X Volumes to a UNC path:
      • Changing all \ (backslash, must be escaped) to /
        • From: \\
        • To: /

      See also worker_path_map & Cross-Platform Rendering

    • Refresh Button Clears Cache: If checked, the local cache will be cleared with each refresh. This is safer (the information is always current) but slower.
    • Job Limit: Restricts the number of jobs returned from the Supervisor. Intended to improve performance in large installations.
    • Job Updated Since: Restricts the number of jobs returned from the Supervisor, by age. Intended to improve performance in large installations.
    • Account Choices: Space-separated list of names to populate the Account field of the submission UI. Somewhat deprecated in favor of tags.
    • Account Customizable: If checked, users can add their own account name(s) at submission time. Deprecated in favor of tags.
    • Num lines to load: Sets the number of lines of logs to load when viewing them via the Administration menu.
    • Clipboard data separator: This sets the character that will separate multiple job ids which have been copy/pasted from the jobs pane.

    Job Tag Display

    Job tags are little bits of information related to a job; these can be anything, but commonly they are some combination of Production (or Show), Shot, Client, etc. This preference makes these tags available in the submission UI. For example, with Show, Seq and Shot set to "Display this field", those tags would show up in the submission UI like so:

    If "Display this field is checked" the tag will be visible as part of the basic submission UI. If "Only in Expert mode" is checked, these tags will be available when the user clicks the Expert Mode button at the bottom of the the submission UI.

    Once these tags are associated with a job, you can use them to filter jobs in the WranglerView UI. This would be the mechanism for larger shops, which are running more than one Production at the same time, to allow users and/or Wranglers to view only the jobs associated with specific shows or other attributes. Even for smaller shops, these tags can be used for charting to visualize resource usage by project, etc.

    Image View Panel

    This sets the width of each thumbnail in the image view panel. The width is measured in pixels.

    Lights Out Management Commands

    Please see the page on Lights Out Management for an explanation of what these preferences are and how to set them.

    Shotgun Configuration

    Qube! can be configured to work closely with Autodesk's Shotgun production management tool. For details on using Shotgun with Qube!, see Shotgun Integration.

    • Shotgun URL: The URL to your Shotgun instance.
    • Script Name: The Shotgun script you have previously created to connect Qube! to Shotgun.
    • Script Key: The Shotgun key that allows your script to execute on the Shotgun server.

    Display Filtering

    • Expert View as default: When set, the job submission dialog (from the Submit menu) will open in Expert Mode by default.
    • Show Admin Menu: Turns on/off the Administration menu item in the top menu bar. If you are configuring the WranglerView UI for advanced users but don't want them to have access to these controls, this control and the next few can be used to hide these kinds of "super user" features, when used in conjunction with Studio-wide Preferences.
    • Show Worker Tab: Turns on/off the Worker tab
    • Show User Permissions Tab: Turns on/off the User Permissions tab
    • Show Dependency Graph View: Turns on/off the Dependency Graph tab
    • Show Selected Job Count: Turns on the additional text showing how many jobs in the job pane are selected:
    • Show Job Submissions: This allows you to shorten the job submission menu to list only those applications that are relevant to your installation. Check the box for each application that you want to appear in the menu, and be sure to uncheck the <ALL> box as well - otherwise, you will still see everything.

    Column List Customization

     

    This section allows you to customize the columns that each tab will show, as well as the order they appear in. For each section, simply check/uncheck the column information you want to see/hide. then use the "Up" and "Down" buttons to move a column up or down in the list. This will correspond to left or right in the WranglerView display. The "Top" and "Bottom" buttons offer shortcuts for moving the columns around.

    The "Add" button is used for adding custom columns. These must be connected to the job's data in order to show anything meaningful.

    • Job: Customize the Jobs panel. #complete, etc denote the count of complete, failed, etc subjobs in that job.
    • Agenda: Customize the panel now labelled Frames/Work that is in the Job Frames panel. This appears just under the Job pane when you choose View -> Show/Hide Job Frames Panel.
    • Instances: Customize the Instances tab in the Job Frames panel. This appears just under the Job pane when you choose View -> Show/Hide Job Frames Panel.
    • Job Groups: Customize the columns in the Metajobs Panel. This appears just above the Job pane when you choose View->Show/Hide Metajobs Panel.
    • Running Instances: Customize the Running Instances panel
    • Workers: Customize the Workers panel
    • Row Color: "Status" uses color to indicate job status. "Alternating" simply alternates blue/white to make it easier to scan large lists.

    Search Field Customization

    This sets the search field priority for various panes. For example, in the image shown, the Jobs context will search the id column first, then the pgrp column, then the name column, for whatever you type into the search box. You can reorder these with the Top,  Up, Down, and Bottom buttons.
    • Regex Search: if checked, the string in the search box will be taken to be a regular expression. Otherwise, whatever you type is searched for literally, and anywhere in each field to be searched. Off by default.

    • Jobs: Define the columns to search, and the order to search them, in the Jobs pane.

    • Workers: Define the columns to search, and the order to search them, in the Workers pane.

    • Running Instances: Define the columns to search, and the order to search them, in the Running Instances pane.

     

     

     

    • No labels