OS X

    Windows / Linux

    File:

    • Preferences - Open the Preferences dialog for the WranglerView. This is different from the Client, Supervisor, and Worker configuration (Administration->Configure). 

      Icon

      On OS X this is found under the "qube" menu

    • Save Preferences - Store the WranglerView Preferences for the user. This is also done automatically when WranglerView closes.
    • Save External Preferences File... - Save the current preferences to a separate file that can be used as defaults for the entire studio. To enable studio defaults, all users should specify the location of this studio defaults file in their ArtistView Preferences. This can also be done when launching it from the commandline (--defaultprefs) or specifying an environment variable (QUBEGUI_DEFAULTPREFS).
    • Open User Preferences Directory... - Opens a file browser in the directory where the user preferences file (qube_guiPreferences.conf) is stored. 

    • Install App UI - Contains a list of items that will install in-application (in-app) submission interfaces to Maya, AfterEffects, and other products. This functionality is stored with the submission interfaces and loaded dynamically by the WranglerView.

    • Open SimpleCmds directory... - Open the SimpleCmds directory (by default it is the simplecmds/ directory alongside the WranglerView executable, eg, /usr/local/pfx/qube/bin/simplecmds in Linux).
    • Update/Install SimpleCmd... - Copy a downloaded SimpleCmd interface to the simplecmds/ directory. The alternate way to do this is to open the simplecmds/ directory with "File->Open SimpleCmds directory" and then drag-and-drop the file there.
    • Reload SimpleCmds - Dynamically reload the SimpleCmd submission interfaces. This is useful if one of the interfaces has been modified, added, or removed.

    • Open AppUI directory... - Open a file browser in the AppUI directory (by default it is the AppUI directory alongside the WranglerView executable, eg, /usr/local/pfx/qube/bin/AppUI in Linux).
    • Update/Install AppUI module... - Copy a new AppUI folder to the AppUI/ directory. The alternate way to do this is to open the AppUI/ directory with "File->Open AppUI directory" and then drag-and-drop the folder there.

    • Close - Exit the application

    View:

    • Refresh - Refresh all the filtered Jobs, Hosts, and User information. 
    • Refresh Selected - Refresh only the selected Jobs. 
    • Refresh (Clear Cache) - Clear the cache of Job and Host information before refreshing all jobs. This will retrieve all new and current information.

    • Find - Search for text in the currently active panel.

    • SearchFilter: Dependent Jobs - Select the upstream and downstream jobs from the selected Job(s).
    • SearchFilter: Clear - Clear the search filter.

    • Show/Hide: Log Panel - Display (or turn off) the Log panel that displays log text at the bottom of the UI. This is on by default.
    • Show/Hide: MetaJobs Panel - Display (or turn off) the MetaJobs panel that shows logical groupings of dependent jobs that share the same Process Group (pgrp). This is turned off by default.
    • Show/Hide: Job Details Panel - Display (or turn off) the Details panel on the right side of the UI. This is on by default.
    • Show/Hide: Job Frames Panel - Display (or turn off) the Frames/Work panel under the main Jobs panel. This is on by default.
    • Show/Hide: Farm Worker Details Panel - Display (or turn off) the additional information panel when looking at the Workers tab. This is on by default.

    Submit:

    • You can submit new jobs through the WrangerView. The Submit menu contains a list of most of the common 2D and 3D content creation software. Submitting jobs from the UI is covered in detail in the Job Submission section of this manual.
    • The submission interfaces (using a simplified python framework) are dynamically loaded into a hierarchical menu. To get a full list and access them, click on File->Open SimpleCmds directory. You can also set additional search paths for these interfaces so all client machines can pull customized versions from the same network directory.
    • See http://www.pipelinefx.com/products/supported-applications for a full list of supported applications. Jobtype documentation can be viewed online at www.pipelinefx.com/support or generated dynamically by the UI under Help->Jobtypes.
    • You can simplify this menu to only show the applications relevant to your installation. This is done through the WranglerView Preferences.

      Icon
      PipelineFX is always updating or adding new application interfaces. The SimpleCmd framework provides a quick and efficient way to add these interfaces, some of them can be done in as little as 15 minutes. If you do not see an interface to a needed application, please contact PipelineFX.

    Administration:

    The Administration menu is provided to allow Administrators the ability to manage and troubleshoot the Qube! farm. All of these actions can also be done from the commandline, though it may be easier to manage from the GUI. More details on Admin functions are found in the Administrator's Guide.

    • Configure Local Host - Configure the current machine's parameters. This modifies the qb.conf file. This will be greyed out if you are not logged in as the local OS-level admin (eg, root, Administrator, etc) with write privileges on that file. This is the same thing as typing
      $ qube --configuration --nogui
      on the command line. 
    • Display Local Running Configuration - Display the configuration of the local machine.
    • Display Qube Supervisor Configuration - Displays the configuration of the supervisor.

    • Install License on (Local) Supervisor - Brings up a dialog to "cut and paste" a license in the qb.lic file. There is a toggle to "Add to" or "Overwrite" an existing qb.lic license file. This must be run on the Supervisor. This will be greyed out if you do not have permission to edit the qb.lic file or you are not running on the Supervisor. See the page on Installing Licenses.
    • Register Windows Password - Register the current user's password (Windows only). This is needed to address a "badlogin" job error when running a job on a Windows Worker that is in "user" mode. See this page for details.

    • Supervisor: Start/Stop - Start or stop the Supervisor on the local machine. Menu item displays the current status.
    • Worker: Start/Stop - Start or stop the Worker on the local machine. Menu item displays the current status.
    • Autostart Supervisor: Start/Stop - Configure the Supervisor autostart on machine boot (local machine).
    • Autostart Worker: Start/Stop - Configure the Worker autostart on machine boot (local machine).

    • Ping Supervisor - Ping the Supervisor and retrieve basic information about version and licensing.
    • Ping Local Worker - Ping the Worker and retrieve basic information about version and licensing.

    • View Supervisor Log - Open the Supervisor log for troubleshooting. You need to be running on the Supervisor for this to work, otherwise it will be greyed out.
    • View Worker Log - Open the Worker log for troubleshooting. One should be logged in to the Supervisor for this option.Note: It will open the log if locally on the Supervisor machine.

    Help:

    • About - Display information about WranglerView. 

      Icon

      On OS X this is found under the "qube" menu

    • Browse Qube! on-line documentation

    • PipelineFX Support
      • Debug logging: Start
      • Mail Debug Log to Support
      • Download a PFX QuickSupport screen-sharing app
      • Report a bug...

    • WranglerView Release Notes - Displays all of the Release Notes for WranglerView going back to version 5.2.
    • WranglerView Commandline Options - Bring up a dialog to display the WranglerView commandline options.

    • Qube User Guide... - Launches a pdf version of the Qube! Users guide.
    • Qube Installation Guide... - Displays a pdf version of the Qube! Installation guide.
    • Qube Administration Guide... - Launch a viewer to display the Qube! Administration guide.

    • SimpleCmd Developer Guide... - Launches local html documentation for writing SimpleCmd submission interfaces for the WranglerView.
    • WranglerView Developer Guide... - Displays developer information about customizing the WranglerView python code.
    • Qube Developer Manual... - Launch a pdf viewer to display this document.
    • Qube Python API Reference... - Launch a pdf viewer to display this document.
    • Qube Jobtypes... - Displays a dynamically generated html document of the current jobtypes, built from the WrangerView UI and the jobtypes installed on this machine. You can also see the Jobtype documentation online at http://www.pipelinefx.com/docs.

    • Visit PipelineFX Forum... - Launch a browser to open the PipelineFX public Forum for posting and receiving answers to Qube! questions.
    • Visit PipelineFX Helpdesk... - Launch a browser to view the PipelineFX Helpdesk website.

    Customizing Menus

    All the main and popup menus are dynamically loaded and exposed to the user. This allows you to add, remove, or modify the menu items in the interface. The default menus are stored under the simplecmds/ directory. See the Developer's Guide for details.

    Icon

    For example, you could add a "ssh <hostname>" menu item to the HostList popup menu to have it ssh into the selected host. Another useful item would be to tie it into the renderfarm's power management controls to start or shutdown machines.


    Default menus under simplecmds/
    menu_banned.py
    menu_jobOutput.py
    menu_jobProcessesRunning.py
    menu_jobSubjobs.py
    menu_jobTasks.py
    menu_jobs.py
    menu_main.py
    menu_metajobs.py
    menu_users.py
    menu_workers.py

     

    • No labels